Developing with the Adobe Creative Suite Extension Builder

This section provides basic information for how to download and work with Adobe Creative Suite Extension Builder

Adobe Creative Suite Extension Builder development environments

Creative Suite extensions can be developed on both Windows and Mac OS X platforms. Before developing extensions, make sure your development environment has these applications installed.

Application

Description

Adobe Creative Suite (CS5 or higher), or at least one of the Suite applications.

Applications that can host extensions developed using Adobe Creative Suite Extension Builder with full support for all features include:

Illustrator®

InCopy®
InDesign®
Photoshop®
Photoshop Extended

Limited support is also available in:

Adobe Bridge

Dreamweaver®

Fireworks®

Flash Pro

Premiere Pro

Adobe Flash® Builder™ 4 or 4.5
or Eclipse 3.5 with the Flash Builder 4 plug-in
or Eclipse 3.6 with the Flash Builder 4.5 plug-in

Development environment in which to create and test extensions. Extensions should be developed against the Extension Builder 3.4 SDK (an amended version of Flex 3.4 SDK).

 

Set your the Eclipse maximum memory usage to allow at least 1024 Mb, by setting the property "-Xmx1024m" in the Eclipse.ini file.

Adobe Creative Suite Extension Manager

Allows the installation of extensions on end-user systems. This application is installed automatically with all CS applications.

 

Installing Adobe Creative Suite Extension Builder

To install Adobe Creative Suite Extension Builder, download the ZIP file and unzip it into a root location (SDKRoot). Alternatively, download the latest SDK directly into Flash Builder from the Adobe Creative Suite Extension Builder update site.

Installing the tools

Adobe Creative Suite Extension Builder is an Eclipse plug-in that you can install in Flash Builder to help you develop extensions. The Extension Builder includes Project and Export wizards, as well as the SDK documentation (guides and reference).

Install Extension Builder in Eclipse with Flash Builder or Flash Builder Standalone:
  1. In Eclipse, choose Help > Install New Software.

  2. In the Install dialog, click Add.

  3. In the Add Site dialog, click Local... to browse to the SDK root folder or enter the URL of the update site.

  4. Name the site CS SDK and click OK to confirm the changes.

  5. Select the new CS SDK site in the "Work with" field.

    -- Select all the Adobe Creative Suite Extension Builder components.
    -- Click Next to confirm the selection.

  6. In the Install Details review dialog, click Next to confirm that you want to install all the components listed.

  7. Accept the terms of license agreements and click Finish.

  8. Re-start  Eclipse as recommended.

Launching the Adobe Creative Suite Extension Builder documentation

Once the  plug-ins have been installed successfully, you can access the Adobe Creative Suite Extension Builder start page from within Flash Builder or Eclipse. This page contains links to the documentation and samples as well as other useful resources.

Documentation resources include:

Importing and running the samples

To import the sample projects into Flash Builder:

  1. Click on File > Import > Other.

  2. In the Import dialog select Adobe Creative Suite Extension Builder > Remote Creative Suite SDK Examples and click Next.

  3. In the Sample remote project names dialog, select all the projects that you want to import, then click Finish.

  4. Verify that you see the selected projects imported into your workspace and no errors are shown.

To run the samples:

  1. Make sure that the application in which you want to run the sample is closed.

  2. Right click in the project you want to run, choose Run As, and choose the application you want to run in.


    This installs the extension and launches the selected application.

  3. In the host application, choose Window > Extensions and the name of the extension you have just installed.

    The extension launches and its window appears on the application's workspace.

 


Next: Creating your first extension

 

 

Copyright © 2011 Adobe Systems Incorporated. All rights reserved.